LEGO Harry Potter: Years 5-7 - Information

LEGO Harry Potter: Years 5-7 - System requirements - Game cover

LEGO Harry Potter: Years 5-7 is a videogame developed by Traveller's Tales, published by Warner Bros. Interactive Entertainment, released on 21 - 11 - 2011 It falls under the following genre categories : Adventure Action


If you are looking to see if you can run LEGO Harry Potter: Years 5-7 on your computer, you've come to the right place. See what are the minimum and recommended for system requirements ( sys req ) for LEGO Harry Potter: Years 5-7



Can I run LEGO Harry Potter: Years 5-7?


If you were wondering if you could run LEGO Harry Potter: Years 5-7, we will help you to get the answer. In order to be able to run LEGO Harry Potter: Years 5-7, you will need a CPU better that Dual Core CPU @ 2GHz (Pentium D or better), more than 1GB RAM, a GPU that is better ranked than Shader Model 3 graphics card (NVIDIA GeForce 6800, 7800, 8xxx or better; ATI X1950 or better) . Check the other system requirements for the game, below.

LEGO Harry Potter: Years 5-7 Minimum system requirements

CPU Dual Core CPU @ 2GHz (Pentium D or better)
RAM 1GB RAM
GPU Shader Model 3 graphics card (NVIDIA GeForce 6800, 7800, 8xxx or better; ATI X1950 or better)
DX -
Operating system Windows XP SP3 Vista or Windows 7
Storage 8.5 GB free HDD space
Sound -
Optical Disk Drive -
Network connection -
Screen resolution -

Recommended system requirements for LEGO Harry Potter: Years 5-7

CPU -
RAM -
GPU -
DX -
Operating system -
Storage -
Sound -
Optical Disk Drive -
Network connection -
Screen resolution -

LEGO Harry Potter: Years 5-7 Information

Developer
Traveller's Tales
Publisher
Warner Bros. Interactive Entertainment
Genres
Adventure Action
Release Date:
21 - 11 - 2011

Related Games to LEGO Harry Potter: Years 5-7