Gotham City Impostors - Information

Gotham City Impostors - System requirements - Game cover

Gotham City Impostors is a videogame developed by Monolith Productions, published by Warner Bros. Interactive Entertainment, released on 07 - 02 - 2012 It falls under the following genre categories : Action FPS


If you are looking to see if you can run Gotham City Impostors on your computer, you've come to the right place. See what are the minimum and recommended for system requirements ( sys req ) for Gotham City Impostors



Can I run Gotham City Impostors?


If you were wondering if you could run Gotham City Impostors, we will help you to get the answer. In order to be able to run Gotham City Impostors, you will need a CPU better that Dual Core CPU 2.5 GHz, more than 1.5 GB RAM, a GPU that is better ranked than 256MB dedicated memory DX9 Video Card (GeForce 8600 or ATI X1800 or better) . Check the other system requirements for the game, below.

Gotham City Impostors Minimum system requirements

CPU Dual Core CPU 2.5 GHz
RAM 1.5 GB RAM
GPU 256MB dedicated memory DX9 Video Card (GeForce 8600 or ATI X1800 or better)
DX DX9.0c
Operating system Windows XP SP3
Storage 7 GB Hard Drive Space
Sound DX9 Compatible Sound Controller
Optical Disk Drive -
Network connection Broadband Internet Connection
Screen resolution -

Recommended system requirements for Gotham City Impostors

CPU Quad Core CPU 2 GHz
RAM 2GB RAM
GPU 512MB DX9 High-Performance Video Card (GeForce 8800 or ATI X1900 or better)
DX DX9.0c
Operating system Windows 7
Storage 7 GB Hard Drive Space
Sound DX9 Compatible Sound Controller
Optical Disk Drive -
Network connection Broadband Internet Connection
Screen resolution -

Gotham City Impostors Information

Developer
Monolith Productions
Publisher
Warner Bros. Interactive Entertainment
Genres
Action FPS
Release Date:
07 - 02 - 2012

Related Games to Gotham City Impostors