Fantasy Strike - Information

Fantasy Strike - System requirements - Game cover

Fantasy Strike is a videogame developed by Sirlin Games, published by Sirlin Games, released on 14 - 09 - 2017 It falls under the following genre categories : Fighting


If you are looking to see if you can run Fantasy Strike on your computer, you've come to the right place. See what are the minimum and recommended for system requirements ( sys req ) for Fantasy Strike



Can I run Fantasy Strike?


If you were wondering if you could run Fantasy Strike, we will help you to get the answer. In order to be able to run Fantasy Strike, you will need a CPU better that Intel Core i5-4302Y @ 1.6GHz, Celeron G1840 @ 2.8 GHz / AMD Athlon II X3, more than 4 GB RAM, a GPU that is better ranked than GeForce GT 555M, 9800 GTX / Radeon R7, HD 8500 . Check the other system requirements for the game, below.

Fantasy Strike Minimum system requirements

CPU Intel Core i5-4302Y @ 1.6GHz, Celeron G1840 @ 2.8 GHz / AMD Athlon II X3
RAM 4 GB RAM
GPU GeForce GT 555M, 9800 GTX / Radeon R7, HD 8500
DX Version 9.0c
Operating system Windows XP+
Storage 2 GB available space
Sound -
Optical Disk Drive -
Network connection -
Screen resolution -

Recommended system requirements for Fantasy Strike

CPU Intel Core i5-5200U @ 2.20GHz, Celeron G3920 @ 2.90GHz / AMD Athlon II X4 645
RAM 8 GB RAM
GPU GeForce GTX 960, Radeon R9 280X
DX Version 9.0c
Operating system Windows XP+
Storage 2 GB available space
Sound -
Optical Disk Drive -
Network connection Broadband Internet connection
Screen resolution -