Bubsy: The Woolies Strike Back - Information

Bubsy: The Woolies Strike Back - System requirements - Game cover

Bubsy: The Woolies Strike Back is a videogame developed by Black Forest Games, published by Accolade, released on 31 - 10 - 2017 It falls under the following genre categories : Adventure Action Platform


If you are looking to see if you can run Bubsy: The Woolies Strike Back on your computer, you've come to the right place. See what are the minimum and recommended for system requirements ( sys req ) for Bubsy: The Woolies Strike Back



Can I run Bubsy: The Woolies Strike Back?


If you were wondering if you could run Bubsy: The Woolies Strike Back, we will help you to get the answer. In order to be able to run Bubsy: The Woolies Strike Back, you will need a CPU better that Intel Core 2 Duo@2.8GHz / AMD Athlon II X2@2.8GHz, more than 3 GB RAM, a GPU that is better ranked than Nvidia GeForce 6800, ATI X1800 XT or higher . Check the other system requirements for the game, below.

Bubsy: The Woolies Strike Back Minimum system requirements

CPU Intel Core 2 Duo@2.8GHz / AMD Athlon II X2@2.8GHz
RAM 3 GB RAM
GPU Nvidia GeForce 6800, ATI X1800 XT or higher
DX Version 9.0
Operating system Windows XP
Storage 3 GB available space
Sound 100% DirectX® 9.0c compatible sound card and the latest drivers
Optical Disk Drive -
Network connection -
Screen resolution -

Recommended system requirements for Bubsy: The Woolies Strike Back

CPU Intel Core i5@2.66GHz / AMD Phenom II X4@3.0GHz
RAM 4 GB RAM
GPU Nvidia GeForce GTX 660, Radeon R 200 series
DX Version 10
Operating system Windows 7 / 8 / 10
Storage 3 GB available space
Sound 100% DirectX® 9.0c compatible sound card and the latest drivers
Optical Disk Drive -
Network connection -
Screen resolution -

Bubsy: The Woolies Strike Back Information

Developer
Black Forest Games
Publisher
Accolade
Genres
Adventure Action Platform
Release Date:
31 - 10 - 2017